Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 20, 2026 - 21:00 CST
Scheduled
Friday, March 20 Time: 11:00 PM β ~12:00 AM EST Impact: The platform will be temporarily unavailable for approximately 1 hour while we upgrade our database to a newer version. We recommend completing any active work before the maintenance window begins.
Posted Mar 16, 2026 - 18:09 CST
This scheduled maintenance affected: API, AccuPAS, tBulk, tPay, and tLink.