Partial Outage - Identity Verification

Incident Report for tevixMD

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 14, 2025 - 09:16 CST

Update

We are continuing to work on a fix for this issue.
Posted Jun 13, 2025 - 18:51 CST

Identified

We are currently experiencing a partial outage affecting our identity verification system. Users are currently unable to complete identity verification.

The issue began at 6:01 PM MT and is limited to this module. All other systems are operating normally. Our team is actively working to resolve the issue.

We’ll continue to share updates as we make progress. Thank you for your patience.
Posted Jun 13, 2025 - 18:51 CST
This incident affects: API, AccuPAS, and tBulk.